[sword-devel] Diatheke doen't show anything...

Greg Hellings greg.hellings at gmail.com
Thu Nov 7 14:49:53 MST 2013


The first thing to test is if diatheke is actually finding your install. To
do this, ask diatheke to give you a module list:

diatheke -b system -k modulelist

If that lists KJV, then the problem is with diatheke or its filter. If that
doesn't list any entries, then it's not finding your install directory
properly. Others might be able to advise you more on that (Perhaps diatheke
has a "verbose" switch while doing this. I haven't tried to diagnose
diatheke problems in a little while so that information isn't on the top of
my head.)


On Thu, Nov 7, 2013 at 3:40 PM, pHep <paul.heptin at gmx.de> wrote:

> Hi,
> I've got a problem with diatheke!
> I've successfully compiled installmgr, libsword, ... and diatheke! (I'm
> working on Windows 8.1 And VS2012)
> I've installed the KJV module with the installmgr. Now I'm trying to lookup
> a verse with diatheke but it doesn't show anything...
> That's my cmd output:
> /C:\Users\Familie\Desktop\SWORD\TEST\installmgr>diatheke -b KJV -k G 1:1
> C:\Users\Familie\Desktop\SWORD\TEST\installmgr>/
> No error and no text...
> I've the mods.d and mods.conf installed at the working dir and also set the
> SWORD_PATH to the working dir!
> What might there be wrong?
> Regards and God bless you
> Paul
> --
> View this message in context:
> http://sword-dev.350566.n4.nabble.com/Diatheke-doen-t-show-anything-tp4653226.html
> Sent from the SWORD Dev mailing list archive at Nabble.com.
> _______________________________________________
> sword-devel mailing list: sword-devel at crosswire.org
> http://www.crosswire.org/mailman/listinfo/sword-devel
> Instructions to unsubscribe/change your settings at above page
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.crosswire.org/pipermail/sword-devel/attachments/20131107/060c0481/attachment.html>

More information about the sword-devel mailing list