[sword-devel] MinimumVersion property in module.conf files

David Haslam dfhmch at googlemail.com
Tue Aug 6 08:20:54 MST 2013

Thanks DM for the further clarification.

So, if my understanding is correct, osis2mod version 1.7.0 transforms the
OSIS such that because at least one instance of "preverse" content must use
the milestone form of the div element, then all div elements in the module
must also be the milestone form rather than the container form.

This raises a further issue, which is whether the identifiers for such
milestone pairs can have (in effect) a quasi-nesting problem, due to how
osis2mod applies its transformations.

What I mean is this:

*Is this a correct outcome?*

<div type="x-milestone" subType="x-preverse" sID="pv1"/> 
<div sID="gen2" type="paragraph"/>
<div type="x-milestone" subType="x-preverse" eID="pv1"/>
<div eID="gen2" type="paragraph"/>

(where the semantic title & text content I have replaced by ".....")

As you will readily observe here, these milestone div element pairs now

Does this confuse the SWORD engine?

The above observation was made by examination of the output from mod2imp
(same build).

Best regards,


View this message in context: http://sword-dev.350566.n4.nabble.com/MinimumVersion-property-in-module-conf-files-tp4652983p4652996.html
Sent from the SWORD Dev mailing list archive at Nabble.com.

More information about the sword-devel mailing list