[sword-devel] More installmgr woes...

Jonathan Marsden jmarsden at fastmail.fm
Tue Sep 1 23:55:25 MST 2009

Greg Hellings wrote:

> You may not be thinking of me in particular, but I have brought that
> up before.  I thought about the SWORD_PATH issue after I ran
> diatheke the first time, and it failed.  So I set SWORD_PATH, and
> tried running installmgr again, and it continued the fail with the
> same error.  I also tried with and without sudo, and no such luck.

FYI, what works for me after a fresh svn head install is:

  [ -d ~/.sword ] && rm -r ~/.sword # For repeated testing only

  export SWORD_PATH=~/.sword
  mkdir -p $SWORD_PATH/mods.d

  echo yes |installmgr -init
  echo yes |installmgr -sc
  echo yes |installmgr -r CrossWire
  echo yes |installmgr -ri CrossWire KJV
  installmgr -l
  diatheke -b KJV -k Jn 3:16

The need for the mkdir -p command seems odd to me, because -init "sounds
like" it should initialize the data area for me, including creating
whatever subdirectories it needs.  But without that mkdir -p, or if I
rfeplace it with mkdir -p $SWORD_PATH , the sequence above does not work
for me here.

You can also avoid all the SWORD_PATH stuff if you take the "central
repository for the machine" approach as recommended in the INSTALL file,
in which case you can do

  sudo rm -r ~/.sword /usr/share/sword/m*  # For repeated testing only
  unset SWORD_PATH # Make sure this is not defined, for testing only

  sudo make install_config # Generates /etc/sword.conf
  sudo mkdir -p /usr/share/sword/mods.d

  echo yes |installmgr -init
  echo yes |installmgr -sc
  echo yes |installmgr -r CrossWire
  echo yes |sudo installmgr -ri CrossWire KJV
  installmgr -l
  diatheke -b KJV -k Jn 3:16

This approach (oddly) creates a few things as root under ~/.sword during
the module install, but otherwise works fine, storing the module content
under the default /usr/share/sword/ as one would expect.

I thought everyone except me was just using the GUI front ends to do
their SWORD module installations... nice to know I am not the only one
who likes working at the shell prompt :)

Incidentally, having to tell installmgr I am not in a persecuted country
*four* times to get one bible installed seems ... excessive.
Fortunately, doing the "echo yes|" thing gets through the prompts, and
so allows me to script my testing!


More information about the sword-devel mailing list