[sword-devel] Mac Autogen question

Manfred Bergmann bergmannmd at web.de
Mon Mar 23 02:55:32 MST 2009

Hi Greg.

I've run into the same issue.
Strangely it has nothing to do with sword sources at least not here.

configure and make works fine for as long as no autogen.sh and  
libtoolize is called.
This screws things up totally and then I'm getting the same error.

Even more strangely all this worked two or three weeks ago when I last  
compiled the library from trunk.


Am 18.02.2009 um 23:15 schrieb Greg Hellings:

> To half answer my questions - the autogen.sh warnings are still there:
> On Wed, Feb 18, 2009 at 4:19 PM, Greg Hellings <greg.hellings at gmail.com 
> > wrote:
>> So I know about 0.001% of what there is to know about autotools, so I
>> don't know what the following means, or even if it should be thought
>> important.  But I just updated to -r2267 SVN on my Mac and ran
>> autogen.sh and got the following:
>> *** Recreating libtool
>> libtoolize
>> libtoolize: putting auxiliary files in `.'.
>> libtoolize: copying file `./ltmain.sh'
>> libtoolize: You should add the contents of the following files to  
>> `aclocal.m4':
>> libtoolize:   `/opt/local/share/aclocal/libtool.m4'
>> libtoolize:   `/opt/local/share/aclocal/ltoptions.m4'
>> libtoolize:   `/opt/local/share/aclocal/ltversion.m4'
>> libtoolize:   `/opt/local/share/aclocal/ltsugar.m4'
>> libtoolize:   `/opt/local/share/aclocal/lt~obsolete.m4'
>> libtoolize: Consider adding `AC_CONFIG_MACRO_DIR([m4])' to  
>> configure.ac and
>> libtoolize: rerunning libtoolize, to keep the correct libtool  
>> macros in-tree.
>> libtoolize: Consider adding `-I m4' to ACLOCAL_AMFLAGS in  
>> Makefile.am.
>> *** Recreating aclocal.m4
>> aclocal
>> *** Recreating configure
>> *** Recreating the Makefile.in files
>> /opt/local is where MacPorts puts its version of autotools, which are
>> the ones being used (obviously) by the script.  Again - not sure what
>> exactly all this might mean, but for those of you who deal with
>> autotools, just thought you might be interested in it. =)
> However, I decided to run an `svn diff` to see if I had changed
> anything in my local tree and found that include/installmgr.h and
> include/config.h both had differences from the server version.  I
> reverted to the original versions and the library now builds (if I
> disable build tests), including the buildtest.cpp that Manfred
> mentioned earlier having problems with.
> However, now I can't get the installmgr to work from the command line.
> The output is pretty verbose - it finds the mods.d/ directory under
> /opt/manual/share/sword and also picks up the locales.d directory in
> the same place.  Then it complains that it thinks there is a
> permissions problem installing.  However, I'm not certain exactly
> where it's trying to install, and I have tried with root permissions
> (I'm running installmgr in a sudo command) and user permissions.
> Anyone have help suggestions on this?  I know I could use the GUI
> installers, but since I don't usually use the GUIs for doing the
> SWORD-based work that I use the Mac for, I'd prefer to have the
> command-line utilities install, since my tools are going to be running
> in that environment.
> --Greg
> _______________________________________________
> sword-devel mailing list: sword-devel at crosswire.org
> http://www.crosswire.org/mailman/listinfo/sword-devel
> Instructions to unsubscribe/change your settings at above page

More information about the sword-devel mailing list