[sword-devel] sword updates

Karl Kleinpaste karl at kleinpaste.org
Thu Sep 13 22:35:42 MST 2007

"Troy A. Griffitts" <scribe at crosswire.org> writes:
> I attempted to reproduce:
> http://crosswire.org/bugs/browse/API-79 which says that InstallMgr 
> cannot update a module.  I also remember having troubles with InstallMgr 
> loosing its head when downloading, but couldn't reproduce the issue 
> tonight by trying to update a module.
> If anyone can reproduce this problem, please let me know soon; 

Troy, I am updated to Sword -r2078 and have rebuilt, and I still get the
same type of failure in F7 with all recent rpm updates.  My config,
scraped from config.log, is:

./configure --enable-tests --with-icu --sysconfdir=/etc --without-conf --prefix=/usr

The output from "installmgr -ri Crosswire KJV" shows this oddness:

* Maxdownload = -1
* Remembering we are in dir pub/sword/raw//
< 226 Directory send OK.
* Connection #0 to host ftp.crosswire.org left intact
* Re-using existing connection! (#0) with host ftp.crosswire.org
* Connected to ftp.crosswire.org ( port 21 (#0)
> CWD /
< 250 Directory successfully changed.
> CWD pub
< 250 Directory successfully changed.
> CWD sword
< 250 Directory successfully changed.
> CWD raw
< 250 Directory successfully changed.
> CWD dead
< 250 Directory successfully changed.

"dead"?  Why is such a dir there, and why is installmgr interested in it?

Following this, it began to obtain random *.conf; I stopped it with ^C.

If I can offer any further info, I'll be glad to, but the problem
definitely still exists.

I have curl-7.16.2-1.

More information about the sword-devel mailing list