[sword-devel] WIN32 test

Stephen Denne sword-devel@crosswire.org
Tue, 6 Mar 2001 00:33:16 +1300

Good news...

These bug went away when I put back the empty options.conf file.


----- Original Message -----
From: "Stephen Denne" <spdlist@ihug.co.nz>
To: <sword-devel@crosswire.org>
Sent: Monday, March 05, 2001 9:48 PM
Subject: Re: [sword-devel] WIN32 test

> Troy :
> Windows ME
> Every time I start it I get:
> Access violation at address 00522E27 in module 'SWORD.EXE'. Read of address FFFFFFFF.
> OK
> I'll include what happens next in case you're interested...
> Clicking OK opens the main window, but shows no commentaries or dictionaries, and only has a tab for ALT translation, of which it
> displays nothing, and the buttons have no images.
> Chosing the menu option to search, I had some searches that worked fine, e.g. searching for wept gave five references. (Showing
> previews worked here - I like the preview column)
> other searches brought forth windows blue screen (after the progress bar had progressed all the way to the right) with errors in
> VWIN32.
> Right clicking in the empty text window and chosing either copy or dictionary lookup resulted in an error message window with no
> error message.
> File | Preferences results in an exact repeat of the error received on startup.
> Exiting the program - I get an error "Abnormal Program Termination"
> Er... version never worked for me either (same problems - except that it refused to quit when asked to, giving an address
> violation error. Again trying to read FFFFFFFF, but from a different location than that at startup)
> Removing the ALT version resulted in the ASV version appearing with exactly the same symptoms (except that there are 72 matches
> wept in ASV)
> A couple of requests: Can the about | help show the full version number?
> In the search results preview - can the reference column be shrinkable? It seems to always bounce back to about half the size that
> the window opened at initially, and can clicking on the preview column show the preview in the lower pane the same as clicking on
> the reference does?
> The verse preview in the search dialogue sometimes shows those square boxes that windows shows when it doesn't have a glyph for
> character you are after. (Spotted at EOL, presumably they're EOL characters) - sample verses showing this for me: Luke 22:62,
> Matthew 26:75 (visible once the window is enlarged)
> Stephen.