[sword-devel] Fwd: Re: Sword - problems with creation of new modul

Joachim Ansorg sword-devel@crosswire.org
Thu, 16 Nov 2000 00:05:45 +0000

Again some problems with the mod2vpl and vpl2mod utilities.
Could somebody help him please?

----------  Weitergeleitete Nachricht  ----------
Subject: Re: Sword - problems with creation of new modul
Date: Wed, 15 Nov 2000 15:21:32 +0100
From: Zdenko Podobný <zdpo@mailbox.sk>
To: Joachim Ansorg <jansorg@gmx.de>


I tried some thing and this happend:
> VPL means "one Verse Per Line". But please noticed that headings are also
> included (e.g. Genesis 0:0, Gensis 1:0 ...)
> The format is :
> [Key name][Two spaces]Text
> Key name is not necessary (you can switch it off with the  last parameter
> (1 or 0))

I prefer to write VPL file in format that I by '../mod2vpl KJV 1 >
[book name][space][chaper]:[verse][space][text]
because text I use for VPL file is not wtihout mistakes. And corect it
in this format is easier.
Also change this format to "[Key name][Two spaces]Text" format is easier
in many wordprocesors than
"[Key name][Two spaces]Text" format to "[book
name][space][chaper]:[verse][space][text]" format

> > Then I run
> > ../vpl2mod ./test.txt /usr/share/sword/modules/texts/rawtext/sk/ 1
> > When it finished I run bibletime. It found 'sk modul' but it showed
> > nothing (only verse numbers :-(.
> If no text appears there's normally a proble with the configuration.
> I tested it, and found out that you ave to create the directory
> /usr/share/sword/modules/texts/rawtext/sk/ before you run vpl2mod.

Well I did it at the test I send you lat time. I repeated it today
(/usr/share/sword/modules/texts/rawtext/sk/ was without file) with the
same result. Then I tried another thing.
I took kjv.conf and adjusted it and save as test.conf (I change only
first 2 lines):

then I created new dir at /usr/share/sword/modules/texts/rawtext/test/
and then I run:
mod2vpl KJV 1 > kjv-1.txt
mod2vpl KJV 0 > kjv-0.txt
vpl2mod ./kjv-0.txt /usr/share/sword/modules/texts/rawtext/ 0

New files apeared at /usr/share/sword/modules/texts/rawtext/test/
Then I ran bibletime: It found module test but it showed nothing. So I
ended bibletime and clear /usr/share/sword/modules/texts/rawtext/test/
Then I ran:
vpl2mod ./kjv-1.txt /usr/share/sword/modules/texts/rawtext/ 1
After this I got this message:
Not a valid KJV ref: Nahum 1:16
appending to ref: Nahum 1:15

This repeated for: Nahum 1:17(appending to 2:0), 2:14(2:13), 2:15-20

New files apeared at /usr/share/sword/modules/texts/rawtext/test/
When I look at 'nt file' the text does nopt started with Mattew 1:1
Then I ran bibletime: It found module test but it showed nothing again.
So I ended bibletime and copied 'ot.vss file' from kjv direstory into
test directory and ran bibletime. I produce some text (it was not
correct adjusted to verses and etc. ). So I closed bibletime, copied 'ot
file'  from kjv direstory into test directory and ran bibletime. Old
testamen worked fine.

Because of I was not sure if there in not some problem with kjv module
(or texts ...) I did the same test with Websters. I produce everything
(also the error message at Nahum) same.

So here are my conclusion:
[1] 'mod2vpl XYZ 1 >xyz.txt' produce bad vpl file -> some problem with
numbering book of Nahum
[2] there is not probelem with configuration (sword , modules, or
bibletime as you suggetsed et your email)
[3] problem is in vpl2mod (from sword-1.5.1a) - it is unable produce
module that will work

I have also queation:
If I want produce only NT How to do it? vpl2mod always started to write
all text in 'ot file' and it don't care that my file consis only Mattew
gospel (my file started something like this:
Mattew 1:1 And here started slovak text

Thanks for help