[sword-devel] Glosses vs Ruby

Nic Carter niccarter at mac.com
Thu Jun 13 00:34:24 MST 2013

FWIW, both a & b are working in the current beta of PS and will be available in the next version on the iOS App Store... :)
As there are no modules in our non-beta repos that support this, I think it's a low priority. I was emailed some private modules & these now work after I changed the OSISRuby line to OSISGlosses :)

On 13/06/2013, at 17:24, David Haslam <dfhmch at googlemail.com> wrote:

> Hi Nic,
> For change of nomenclature, I think this means the SWORD API needs to be
> tweaked 
> (a) to actually render OSIS glosses properly
> (b) to toggle module display using GlobalOptionFilter=OSISGlosses
> Though it would do no harm for a recompiled PS to not be backwards
> compatible with a few modules in the beta repo., what about other
> front-ends?
> Also, before we implement (b), we should at least add *OSISGlosses* to the
> table in 
> http://crosswire.org/wiki/DevTools:conf_Files#Elements_required_for_proper_rendering
> OSISRuby could be removed either now or later (after we reach a consensus).
> At least one thing is in your favour - *OSIS Reference 2.1.1* contains no
> mention of the word "Ruby".
> ybic,
> David
> --
> View this message in context: http://sword-dev.350566.n4.nabble.com/Glosses-vs-Ruby-tp4652524p4652526.html
> Sent from the SWORD Dev mailing list archive at Nabble.com.
> _______________________________________________
> sword-devel mailing list: sword-devel at crosswire.org
> http://www.crosswire.org/mailman/listinfo/sword-devel
> Instructions to unsubscribe/change your settings at above page

More information about the sword-devel mailing list