[sword-devel] Method Name Normalization

Nic Carter niccarter at mac.com
Mon Jan 21 04:28:25 MST 2013

On 20/01/2013, at 3:13 AM, Troy A. Griffitts <scribe at crosswire.org> wrote:

> Headings() has been renamed to setIntros(bool) and bool isIntros()
> Headings() -- used to turn on chapter, book, testament, and module introductions, has frequently been a point of confusion with the global option "Headings" -- used to turn on and off section headings in the text.  This new property name will hopefully remove that confusion.

Is there a reason for this being the abbreviation and not "setIntroductions(bool)" and "isIntroductions()"?
I find it strange that you've fixed up "Lang()" and introduced "Intros()"...
But, thanks for this change. It was confusing before! :)

Also, I think you forgot a "const" in echomod.cpp? (one of the tests.) I say "think" cause it threw an error for me and then I realised I didn't need that in my stuff, so I simply deleted it rather than "fix" it...  ;)

Thanks for all of this. :) Still double checking it all with my stuff, but looking good so far :)

Thanks, ybic
	nic...  :)

More information about the sword-devel mailing list