[sword-devel] Method Name Normalization

Troy A. Griffitts scribe at crosswire.org
Sat Jan 19 12:30:55 MST 2013

Peter von Kaehne <refdoc at gmx.net> wrote:

>On Sat, 2013-01-19 at 17:13 +0100, Troy A. Griffitts wrote:
>> Headings() has been renamed to setIntros(bool) and bool isIntros()
>> Headings() -- used to turn on chapter, book, testament, and module 
>> introductions, has frequently been a point of confusion with the
>> option "Headings" -- used to turn on and off section headings in the 
>> text.  This new property name will hopefully remove that confusion.
>Does this mean that headings and intros are now formally separated?

They always have been. They have never had anything to do with each other.

>Right now both are turned on jointly, 

Maybe a tool or frontend you've used does this, bit the engine has no correlation between the two.


while a more natural way would be
>to turn on headings and turn on intros separately of each other - maybe
>making latter dependent on former, but former should be possible
>sudden appearance of huge intro paragraphes.
>sword-devel mailing list: sword-devel at crosswire.org
>Instructions to unsubscribe/change your settings at above page

Sent from my Android phone with K-9 Mail. Please excuse my brevity.

More information about the sword-devel mailing list