[sword-devel] Method Name Normalization

Peter von Kaehne refdoc at gmx.net
Sat Jan 19 11:31:59 MST 2013

On Sat, 2013-01-19 at 17:13 +0100, Troy A. Griffitts wrote:
> Headings() has been renamed to setIntros(bool) and bool isIntros()
> Headings() -- used to turn on chapter, book, testament, and module 
> introductions, has frequently been a point of confusion with the global 
> option "Headings" -- used to turn on and off section headings in the 
> text.  This new property name will hopefully remove that confusion.

Does this mean that headings and intros are now formally separated?
Right now both are turned on jointly, while a more natural way would be
to turn on headings and turn on intros separately of each other - maybe
making latter dependent on former, but former should be possible without
sudden appearance of huge intro paragraphes.


More information about the sword-devel mailing list