[sword-devel] Alternate Versification question

Greg Hellings greg.hellings at gmail.com
Wed Aug 8 18:31:51 MST 2012

Some have been pruned in the past because they were either duplicates
or similar. It is also possible that some of the documentation is out
of date. The best way to know for sure is to look at the installed
header files, if you're on Linux, to see which ones are included. Each
versification is listed in a header file with the name canon_<name>.h

Modifications must also be made in a few others places once that file
is in place. If the one you need isn't supported (I don't see LXX or
GNT at present) then you're welcome to create such a file and submit
it along with your module.


On Wed, Aug 8, 2012 at 8:25 PM, Andrew Thule <thulester at gmail.com> wrote:
> osis2mod -h lists the following versifications supported:
>   -v <v11n>              specify a versification scheme to use (default is KJV)
>                                  Note: The following are valid values for v11n:
>                                         Catholic
>                                         Catholic2
>                                         German
>                                         KJV
>                                         KJVA
>                                         Leningrad
>                                         Luther
>                                         MT
>                                         NRSV
>                                         NRSVA
>                                         Synodal
>                                         Vulg
> However, this following page list others (such as LXX and GNT):
> http://svn.crosswire.org/wiki/Alternate_Versification/System_Identification
> I can see from this page that support for some of the versification
> schemes appears to be a function of the development cycle with German,
> Luther and Vulgate being added in 1.6.1 and Catholic and Catholic2
> being added in 1.6.2:
> http://svn.crosswire.org/wiki/Alternate_Versification#Supported_versification_systems
> Cutting to the chase, my question is this, are versification schemes
> such as LXX and GNT to be expected in subsequent development
> iterations or are there otherways to employ them?  I'm specifically
> interested in LXX as I've got valid OSIS for LXXE, but I'm constantly
> banging into versification errors/warning when I create my module
> ie.
> INFO(V11N): Hos.7 is not in the NRSVA versification. Appending content
> to Hos.6.11
> INFO(V11N): Tob.8 is not in the NRSVA versification. Appending content
> to Tob.7.16
> INFO(V11N): Tob.11 is not in the KJVA versification. Appending content
> to Tob.10.12
> INFO(V11N): Sir.30.27 is not in the KJVA versification. Appending
> content to Sir.30.25
> ERROR(REF): Invalid osisID/annotateRef: 4Macc.18.1
> etc.
> ~A
> _______________________________________________
> sword-devel mailing list: sword-devel at crosswire.org
> http://www.crosswire.org/mailman/listinfo/sword-devel
> Instructions to unsubscribe/change your settings at above page

More information about the sword-devel mailing list