[sword-devel] Ubuntu 12.04 ....

Barry Drake bdrake at crosswire.org
Mon Apr 23 01:57:48 MST 2012

On 23/04/12 02:46, Karl Kleinpaste wrote:
> I wasn't aware, but you'll have to be more specific: What sort of 
> dependency conflicts? What does apt-get complain about?

Specifically, the packages offered under 12.04 use libsword8 for 
BibleTime and libsword9 for Xiphos.  If BibleTime is installed first, 
apt-get gives:
~$ sudo apt-get install xiphos
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
   libgsf-1-114 libgsf-1-common libsword-common libsword9 xiphos-data
Suggested packages:
The following packages will be REMOVED
   bibletime libsword8
The following NEW packages will be installed
   libgsf-1-114 libgsf-1-common libsword-common libsword9 xiphos xiphos-data
0 upgraded, 6 newly installed, 2 to remove and 0 not upgraded.
Need to get 0 B/5,108 kB of archives.
After this operation, 5,543 kB of additional disk space will be used.
Do you want to continue [Y/n]?

Continuing (obviously) kills BibleTime.  If the process is done 
installing Xiphos first, apt-get refuses to replace the later libsword 
with the earlier one and fails to install.  It is clearly a packaging 
problem - we just need a packaged version of a later build of BibleTime.

God bless,        Barry.

 From Barry Drake (The Revd) Health and Healing advisor to the East
Midlands Synod of the United Reformed Church.  See
http://www.urc5.org.uk/index for information about the synod, and
http://www.urc5.org.uk/?q=node/703 for the Synod Healing pages.

Replies - b.drake at ntlworld.com

More information about the sword-devel mailing list