[sword-devel] Wycliffe modules and beta testing

Chris Little chrislit at crosswire.org
Sun Jan 18 15:30:26 MST 2009

Peter von Kaehne wrote:
> I just guess it is time again to start testing and tried to parcel up
> the job into what needs to be done, what should be done and what can wait.
> You have updated a whole bunch of modules in November following various
> updates to osis2mod.
> The trouble is that there are still a number of modules which are
> waiting for 1.5.12 updates while others only were waiting for osis2mod
> updates.

Modules requiring 1.5.12 will quickly become modules requiring 1.5.13 if 
we don't get any of the requisite code written. I think I wrote, but 
haven't tested, the OSISRuby filter, so those Japanese Bibles might be 
ready when we release 1.5.12.

The new content compiled with osis2mod may need to wait on additional 
updates to osis2mod. A little testing of some recent releases in BibleCS 
& BD showed odd behavior with red-letter text, but I didn't have time to 
check whether the fault lay with osis2mod or simply with bad source 

A few of the GenBooks are probably ready to go, as are a few Bibles. But 
wholly independent of that are some problems with the server 
configuration that I haven't had time to track down--though I suspect a 
problem with permissions. Until that is corrected, downloads from the 
webpage don't work, so new releases are probably a bad idea.


More information about the sword-devel mailing list