[sword-devel] SWORD 1.6.0RC1

Manfred Bergmann bergmannmd at web.de
Mon Apr 13 14:51:09 MST 2009

Hmm yeah, the icutest doesn't build here too.
Same error with malloc.h.

However if you include:
#include <sys/malloc.h>

It works. Strange though since malloc.h is some basic libc stuff.
icutest.cpp is the only test which includes malloc.h.
How is this on other systems?


Am 13.04.2009 um 22:28 schrieb Greg Hellings:

> Tried building on Mac from the command-line (I think that Manfred is
> moving toward using the IDE, but command-line is probably easiest for
> most people, since the library uses autotools which specializes in
> Unix makefiles).  The library built and compiled fine, but the icutest
> doesn't build.  It complains about not being able to find malloc.h --
> I've mentioned this before and was just told to disable tests, which
> works, but it really should build with tests before we release!
> malloc.h is around on the system - in fact 'find / -name malloc.h'
> returns 32 different copies of it.  The most useful ones are probably:
> /usr/include/malloc/malloc.h
> /usr/include/objc/malloc.h
> /usr/include/sys/malloc.h
> The rest are for specific SDK frameworks that I have installed.  I
> will proceed to finish the build without the tests and compile against
> BibleTime, but having our own internal tests fail to compile just
> looks bad.
> --Greg
> _______________________________________________
> sword-devel mailing list: sword-devel at crosswire.org
> http://www.crosswire.org/mailman/listinfo/sword-devel
> Instructions to unsubscribe/change your settings at above page

More information about the sword-devel mailing list