[sword-devel] Lucene, new version soon

Eeli Kaikkonen eekaikko at mail.student.oulu.fi
Sun Jan 13 10:50:11 MST 2008

On Sun, 13 Jan 2008, DM Smith wrote:
> With regard to cLucene, this is important because cLucene is still at
> 1.4.3 compatibility, even after Lucene 2.0 was released 19 months ago
> (May 2006). There are only a few active developers on cLucene and
> while much has been done to port 2.0, there still remains much to be
> done. It still cannot read or create a 2.x index.

Thanks for the report.

This means that we have either to help - or to pray hard. Search is one
of the most important features of any Bible software and the fast lucene
engine is a great advantage for us even though the Sword library has
other engines.

I suggest we all pray that the clucene project gets more
developers/developer time/solutions to problems.

	Eeli Kaikkonen (Mr.), Oulu, Finland
	e-mail: eekaikko at mailx.studentx.oulux.fix (with no x)

More information about the sword-devel mailing list