[sword-devel] Building GnomeSword on Fedora 10

fred smith fredex at fcshome.stoneham.ma.us
Fri Dec 19 09:51:46 MST 2008

On Thu, Dec 18, 2008 at 11:12:41PM -0500, Karl Kleinpaste wrote:
> fred smith <fredex at fcshome.stoneham.ma.us> writes:
> > checking for GNOME... no
> > so, what is it trying to tell me in that last line? That I don't have
> > Gnome on my system? Balderdash! :) I surely do!
> configure is looking for these packages as its expectations of gnome:
> glib-2.0 gtk+-2.0 libgnomeprintui-2.2 libgnomeui-2.0 libxml-2.0 libglade-2.0
> (as found most readily in configure.in)


Do you mean libxml2, or do you mean libxml ? if the latter, that's REALLY old
and I don't see any libxml packages for Fedora. I could always build one....

And gtk+-2.0 doesn't seem to be available for Fedora 10, as far as I
can see. (and I've got RPMFusion free and nonfree enabled.) I see only
gtk+-devel-1:1.2.10-66.fc10. That's strange, becasue I thought gtk+-1.xx
was long obsolete.

There's also a gnomesword RPM for F10 that I tried to isntall, but since
there isn't a RPM of the Sword backend itself, and I have to compile it
from source, RPM refuses to install the gnomesword RPM because RPM doesn't
see the non-RPM sword. I know, I could override that, but I'd rather not.

Suggestions/slaps welcome! :)

---- Fred Smith -- fredex at fcshome.stoneham.ma.us -----------------------------
                       I can do all things through Christ 
                              who strengthens me.
------------------------------ Philippians 4:13 -------------------------------
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
URL: <http://www.crosswire.org/pipermail/sword-devel/attachments/20081219/5f040155/attachment-0001.bin>

More information about the sword-devel mailing list