[sword-devel] Version stamp format

Karl Kleinpaste karl at kleinpaste.org
Mon Oct 22 12:41:24 MST 2007

peter <refdoc at gmx.net> writes:
> That is curious. So if I replace a module 1.1 with a "new" module 1.0, I
> would actually get a message that my installed module can be updated?

The problem is more practically seen in e.g. picking up the beta Barnes
commentary, labeled 1.2.  If one thereafter surfs the main Crosswire
repo, where the older Barnes is present as 1.1, one could have the
impression that a misguided "refresh" to an older version is in order.

About 10min after I made that comment, a 2-character change in GS gave
me the appropriate semantic, so that GS does not now generate a refresh
icon when one has Barnes 1.2 already installed and one is looking at the
main Crosswire repo with Barnes 1.1 available.  The enhancement will
show up publicly in GS 2.3.2, in a month or two.

More information about the sword-devel mailing list