[sword-devel] checking in

Daniel Glassey dglassey at gmail.com
Tue Jun 28 20:43:15 MST 2005

On 26/06/05, Troy A. Griffitts <scribe at crosswire.org> wrote:
> Hey guys.  Sorry I don't have time to respond to all the discussion
> going on, but I am happy that it is being discussed and pray for your
> ideas and work!
> A few brief comments.
> I think the
> int VerseKey::getChapterMax()
> int VerseKey::getVerseMax()
> ideas are great.


> I don't understand or like the name of BookNew()   :)  It's not
> camelCase, and I don't understand its need or purpose.

It was NewBook() and I just copied whoever came up with the name of
NewIndex() ;) I think that was to provide something like Index() but
slightly different.

I'll explain later what I was aiming for.

> I don't think we should remove Testament (save renaming it to
> get/setTestament() when we do that PCR)
> I realize the TreeVerseKey work might need an additional level:  $$$/Old
> Testament/Genesis/Chapter 1/Verse 1/
> but I think that's ok.  Let a document put apocryphal books into the
> 'testament' they choose.

I'll leave it to the people that will be creating those docs to decide
what they want. I was a bit rash with it and my suggestions probably
aren't necessary. However, we want to provide is what people on the
frontends and doc creation need. So I guess we should find that out

> Things are going great here!  We just left Ancient Corinth and I learned
> so much which directly impacts how I read Scripture!  We're having a
> Sabbath rest in Turkey before we explore sites here. 

Glad things are going well there :)


More information about the sword-devel mailing list