[sword-devel] Windows beta 1.5.8pre1

Chris Little chrislit at crosswire.org
Wed Feb 9 00:06:54 MST 2005

Lynn Allan wrote:
> 1.5.8pre1 on Windows seems to work ok once it is put into the proper
> directory (same as earlier 1.5.x)
> I did hit an access violation specifying the 2nd Bible for Parallel:
> "Access violation at address 0040913D in module 'sword-1.5.8pre1.exe'.
> Read of address 00000000."
> But Sword seemed to recover and keep working. Parallel verses do show
> up. Interesting.
> Same access violation happened when specifying the third Bible for
> parallel.

These are those null pointer dereferences. There are sure to be more. 
Keep the bug reports coming, and feel free to post them at 
www.crosswire.org/bugs. You can adjust this bug with any further details 
at http://www.crosswire.org/bugs/browse/BCS-16 if you like (or monitor 
its progress).

> I tried the "Create Index" for searching the ACV. It is still grinding
> and taking a loooooong time ... almost seems locked up, but I'll wait
> a while longer. Every minute or so, another block appears in the
> "Progress Indicator" so this could take a while.  Seems a little more
> than half done after 13 minutes on an older 933 mhz PIII ... done @ 25
> minutes. Is this expected behavior?

Yeah, for me, on a 1.5GHz P4-M, it took 20min to index the NASB. The ACV 
just took me 18min. If we can't get the time down to a reasonable level, 
we may post indexes for download (the NASB index is about 6.7mb or 2.5mb 

> The "Search" dialog is behind the main window, and I'm having trouble
> getting it to the front. Ooops ... got another access violation ...
> same info as above.

I find this behavior (the hidden search window) annoying too, but I'm 
not sure what we should do about it.

> Hmmmm,  search for "Jesus" didn't find any matches. Found 932 before.
> No matches for "God"???

I get 932 results on a search for Jesus in the ACV. I think your index 
may have failed to build. Did you try to cancel it somehow?


More information about the sword-devel mailing list