[sword-devel] New error on building CVS of Sword

Troy A. Griffitts sword-devel@crosswire.org
Sat, 22 Feb 2003 14:31:48 -0700

	I believe your initial problem was that someone hadn't added 2 new 
filters to the unix make system, although they were referenced in SWMgr.

	Your current problem is that CVS HEAD is currently torn appart to 
replace an inadequate component that was used everywhere.  We're 
currently in the process of stitching it back up.

	The broken commit was done so that we could get help from everyone to 
make the large number of changes necessary to get thing back in order. 
And we've had many people contribute (THANK YOU!).  So, give it a few 
more days, and watch the list.  I'll definitely post a message when CVS 
is compiling again.  Thanks for your testing and help.  It is most 


Steven P. Ulrick wrote:
> Hello, again, Everyone :)
> I hate to be a bother again, but now I'm getting a new error when I try
> to "make" the CVS of Sword.  I haven't received a response on my last 3
> requests for help on this problem, so I thought I'd just keep trying,
> and report any new errors as they occured.  Please refer to 3 of my last
> four messages on this problem for a history on what I've been seeing
> with this problem.  Just as an experiment, I tried to download a new
> copy of the CVS on Sword, and I couldn't even get that to work.  At
> least I can still update :)
> The error messages I've been getting over the week that I have been
> trying to get this to work have been ALMOST the same.  The main
> difference is, that sometimes they occur right after I run "make",
> sometimes "make" will run a few minutes, looking like it's finally
> working, and then end with the same error message.
> Here's a small quote from the first error message I posted:
> make[2]: *** [testlib] Error 1
> make[2]: Leaving directory `/home/steve/CVS/sword'
> make[1]: *** [all-recursive] Error 1
> make[1]: Leaving directory `/home/steve/CVS/sword'
> make: *** [all] Error 2
> Here is a complete quote from the second error message I posted:
>>Making all in .
>>make[2]: Entering directory `/home/steve/CVS/sword'
>>source='testlib.cpp' object='testlib.o' libtool=no \
>>depfile='.deps/testlib.Po' tmpdepfile='.deps/testlib.TPo' \
>>depmode=gcc3 /bin/sh ./depcomp \
>>g++ -DHAVE_CONFIG_H -I. -I. -I. -I ./include  -DUSBINARY  -g -O2
>>-ftemplate-depth-25 -c -o testlib.o `test -f 'testlib.cpp' || echo
>>/bin/sh ./libtool --mode=link g++  -g -O2 -ftemplate-depth-25   -o
>>testlib  testlib.o -L./lib -lsword -lz 
>>mkdir .libs
>>g++ -g -O2 -ftemplate-depth-25 -o testlib testlib.o 
>>-L/home/steve/CVS/sword/lib /home/steve/CVS/sword/lib/.libs/libsword.a
>>/home/steve/CVS/sword/lib/.libs/libsword.a(swmgr.o): In function
>>/home/steve/CVS/sword/lib/../src/mgr/swmgr.cpp:201: undefined
>>reference to `sword::OSISPlain::OSISPlain[in-charge]()'
>>collect2: ld returned 1 exit status
>>make[2]: *** [testlib] Error 1
>>make[2]: Leaving directory `/home/steve/CVS/sword'
>>make[1]: *** [all-recursive] Error 1
>>make[1]: Leaving directory `/home/steve/CVS/sword'
>>make: *** [all] Error 2
> And here is the complete quote from my third posting on this problem:
> Next you might try something like:
> make
> su
> make install
> (and optionally)
> make install_config
> make register
> make  all-recursive
> make[1]: Entering directory `/home/steve/CVS/sword'
> Making all in lib
> make[2]: Entering directory `/home/steve/CVS/sword/lib'
> Makefile:603: *** missing separator.  Stop.
> make[2]: Leaving directory `/home/steve/CVS/sword/lib'
> make[1]: *** [all-recursive] Error 1
> make[1]: Leaving directory `/home/steve/CVS/sword'
> make: *** [all] Error 2
> And last but not least, here is the latest error I get after updating
> the CVS of Sword, running ./usrinst.sh and then make:
> source='../src/modules/filters/gbfstrongs.cpp' object='gbfstrongs.lo'
> libtool=yes \
> depfile='.deps/gbfstrongs.Plo' tmpdepfile='.deps/gbfstrongs.TPlo' \
> depmode=gcc3 /bin/sh ../depcomp \
> /bin/sh ../libtool --mode=compile g++ -DUSE_AUTOTOOLS   -DUNIX  -I. -I.
> -I.. -I../include  -DUSBINARY  -g -O2 -ftemplate-depth-25 -c -o
> gbfstrongs.lo `test -f '../src/modules/filters/gbfstrongs.cpp' || echo
> './'`../src/modules/filters/gbfstrongs.cpp
> g++ -DUSE_AUTOTOOLS -DUNIX -I. -I. -I.. -I../include -DUSBINARY -g -O2
> -ftemplate-depth-25 -c ../src/modules/filters/gbfstrongs.cpp -MT
> gbfstrongs.lo -MD -MP -MF .deps/gbfstrongs.TPlo
> ../src/modules/filters/gbfstrongs.cpp:47: no `char
>    sword::GBFStrongs::ProcessText(char*, int, const sword::SWKey*, const
>    sword::SWModule*)' member function declared in class
> `sword::GBFStrongs'
> make[2]: *** [gbfstrongs.lo] Error 1
> make[2]: Leaving directory `/home/steve/CVS/sword/lib'
> make[1]: *** [all-recursive] Error 1
> make[1]: Leaving directory `/home/steve/CVS/sword'
> make: *** [all] Error 2
> If this problem won't be corrected until the issues that Troy refers to
> in the thread "NEED A HAND" are resolved (In that thread, he said the
> CVS is broken.  The only reason I keep bothering you with this is
> because even though I haven't heard that the CVS was fixed again, all of
> a sudden I was able to update it again.  For a while, I couldn't even
> finish the update.  It would hang when it was updating the "perl"
> directory.), please at least let me know so I can stop bothering you
> with this :)
> Thanks in advance for your help :)
> Steven P. Ulrick
> _______________________________________________
> sword-devel mailing list
> sword-devel@crosswire.org
> http://www.crosswire.org/mailman/listinfo/sword-devel