[sword-devel] Error running "make" on CVS of Sword - New

Steven P. Ulrick sword-devel@crosswire.org
Wed, 19 Feb 2003 02:44:31 -0600

On Mon, 17 Feb 2003 02:23:27 -0600
"Steven P. Ulrick" <spu@faith4miracle.org> wrote:

> Hello, Everyone :)
> While attempting to run "make" on the CVS of Sword, I got the
> following error:
> Making all in .
> make[2]: Entering directory `/home/steve/CVS/sword'
> source='testlib.cpp' object='testlib.o' libtool=no \
> depfile='.deps/testlib.Po' tmpdepfile='.deps/testlib.TPo' \
> depmode=gcc3 /bin/sh ./depcomp \
> g++ -DHAVE_CONFIG_H -I. -I. -I. -I ./include  -DUSBINARY  -g -O2
> -ftemplate-depth-25 -c -o testlib.o `test -f 'testlib.cpp' || echo
> './'`testlib.cpp
> /bin/sh ./libtool --mode=link g++  -g -O2 -ftemplate-depth-25   -o
> testlib  testlib.o -L./lib -lsword -lz 
> mkdir .libs
> g++ -g -O2 -ftemplate-depth-25 -o testlib testlib.o 
> -L/home/steve/CVS/sword/lib /home/steve/CVS/sword/lib/.libs/libsword.a
> -lz
> /home/steve/CVS/sword/lib/.libs/libsword.a(swmgr.o): In function
> `sword::SWMgr::init()':
> /home/steve/CVS/sword/lib/../src/mgr/swmgr.cpp:201: undefined
> reference to `sword::OSISPlain::OSISPlain[in-charge]()'
> collect2: ld returned 1 exit status
> make[2]: *** [testlib] Error 1
> make[2]: Leaving directory `/home/steve/CVS/sword'
> make[1]: *** [all-recursive] Error 1
> make[1]: Leaving directory `/home/steve/CVS/sword'
> make: *** [all] Error 2

Hello, Everybody :)
I've tried a few updates, and a few "make distclean"'s since the above
quoted error message, and I'm still getting the same error message.
AFTER I got the above quoted error, I had a few failed attempts at
Slackware 8.1, so I don't have the Sword or Bibletime CVS's installed at
all :)  When I tried to download Sword from the website to get me by
until I could get the CVS's of Sword and Bibletime working, I got the
following error from the website (the full error is a lot longer:

HTTP Status 500 -

type Exception report


description The server encountered an internal error () that prevented
it from fulfilling this request.


javax.servlet.ServletException: org/apache/jsp/swordapi_jsp (Truncated
class file)
	at org.apache.jasper.servlet.JspServlet.service(Unknown Source)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(Unknown

For the full error message, I uploaded it to the following location for
your investigation:

I'll look around to see if I have Sword 1.5.5 laying around somewhere,
but any help you can give me will be greatly appreciated :)

Steven P. Ulrick

Oh yeah, I just had an inspiration, and I am now downloading Sword 1.5.5
from ftp.crosswire.org.  But you help on the above issue is truly
appreciated :)