[sword-devel] compiling with gcc 3.1
Sat, 22 Jun 2002 16:26:02 +0100
I've just committed some fixes to gcc 3.0 Unfortunately now that I've
upgraded to 3.1 the problem that occurred before with RedHat appears to have
made it into core gcc.
with this Debian/unstable system gettext is already defined as a macro by the
time you get to rawverse.h etc
Would anyone strongly object if I rename 'gettext' to 'getText' or something
else? That specifically includes all you frontend writers that ever call
rawstr, rawstr4, rawverse or zverse::gettext directly (which I don't think
should be any, but just checking).
btw suggesting that gcc do the changing is not a solution ;)
P.S. looking at getting --enable-vcl working now and the swig automake stuff