[sword-devel] RawVerse::gettext etc
Fri, 25 Jan 2002 21:38:14 -0600
On Friday 25 January 2002 16:22, you wrote:
> On Friday 25 January 2002 10:38, you wrote:
> > > > It already has a different name in zverse (swgettext), but
> > > > I'm not convinced this is the most intuitive name it could
> > > > be.
> > > >
> > > > getText is another option though that would be very prone to
> > > > typos. Or alternatively we could #undef gettext in defs.h.
> > >
> > > These approaches can lead to confusion...
> > > Why not use the C++ namespace capability, that is what it was
> > > icnluded for. Call it 'swordspace' or something like that...
> > Good idea. Don't know anything about c++ namespaces yet myself.
> > anyone?
Opps! SHould be:
> And do a find on 'namespace' in the left panel. The concept is as
> easy as falling off a log, and eliminates a lot of possible
> problems with name collisions.