[sword-devel] RawVerse::gettext etc
Fri, 18 Jan 2002 14:53:48 -0000
According to this bug on sourceforge
gettext is already defined as a macro in Redhat 7.2 gcc (see
src/utilfuns/regex.c for what it probably is). Looks like it would be best to
rename the gettext functions in rawverse, rawstr, rawstr4.
It already has a different name in zverse (swgettext), but I'm not convinced
this is the most intuitive name it could be.
getText is another option though that would be very prone to typos.
Or alternatively we could #undef gettext in defs.h.
Maybe readtext describes what it does better, reading the text into a
provided buffer rather than returning it?
(fwiw I'd go for readtext)
Do You Yahoo!?
Get your free @yahoo.com address at http://mail.yahoo.com