[sword-devel] Diatheke

Don A. Elbourne Jr. sword-devel@crosswire.org
Tue, 2 Jan 2001 10:20:28 -0600

I sent this to the list a couple weeks ago, but it never went through. Here
it is again:


I think I'm getting close. I'm trying to install diatheke on my server. The
server is running Red Hat Linux and I telnet in. I've been using Linux for
about a week or so, so my experience level is rather low. I have figured out
how to do basic commands. The commands are not much different from DOS and
so I'm relatively comfortable since I started computing before Windows.

Anyway, this is how far I've gotten so far...

I placed all of sword-1.5.tar.gz into a directory /sword and placed
everything from kjv.zip into /html/sword

I copied the contents of /html/kjv/kjv.conf into /sword/mods.onf and changed
the paths like this:



Then I ran make. It must have worked because my screen filled with gibberish
and a 10.5 MB file was created in the /sword/lib directory. The file is
named libsword.a

I then put everything from diatheke2.0.zip into my /cgi-bin/ directory.

I had to run make a few times to get it to work. I had to edit the first
line of makefileto
root := /home/sites/site84/sword

It took me a while to figure out this is where my stuff is on the server.
When I made this change, make worked and it created two files called
diatheke.o and diatheke.d

I then moved both of these files to /cgi-bin/

I changed the permissions on diatheke.pl to be able to execute but when I do
./diatheke.pl it says "no such file or directory" I'm running it from within
my /cgi-bin/

when I try to access it from the browser
http://elbourne.org/cgi-bin/diatheke.pl I get "Internal Server Error"

If anyone has read down this far, can you see any obvious thing I'm doing
wrong. Like I said, I'm new to Linux and perl and so I'm not real sure what
all I'm doing, but I did get this far. That ought to count for something.

Any help would be apreciated.

Don A. Elbourne Jr.