[sword-devel] diatheke was su

Don A. Elbourne Jr. sword-devel@crosswire.org
Mon, 5 Feb 2001 10:52:05 -0600

OK. Thanks.

Actually, I don't know if I need to do su, because I am just wanting to run
Diatheke on my server. If I'm understanding how things work, I don't even
need to run "make install" after I have already run "make." Is this correct?
After running make I have the libsword.* files.

I then wen on to compile diatheke. I ran make and it seemed to work fine. I
moved diatheke, libsword.so, and libsword.a to my /cgi-bin/. But when I try
to run diatheke, I get:

./diatheke: error in loading shared libraries: libsword.so: cannot open
shared object file: No such file or directory

In my limited knowledge of things, I'm assuming that libsword.so is looking
for a "shared object file" and that it or diatheke can not find it. What is
it, whet is it and is there a config file somewhere that I can change to let
diatheke know where to look?

If it would help, I could log the make process for Sword and diatheke to a
text file, maybe that will help someone help me figure out what I need to do

In Christ,

Don A. Elbourne Jr.

> -----Original Message-----
> From: owner-sword-devel@crosswire.org
> [mailto:owner-sword-devel@crosswire.org]On Behalf Of kbrannen@gte.net
> Sent: Sunday, February 04, 2001 8:35 PM
> To: sword-devel@crosswire.org
> Subject: Re: [sword-devel] su
> "Don A. Elbourne Jr." wrote:
> >
> > I'm trying to compile Sword on my web server again. I tried
> about a month
> > ago and got too frustrated.  :-) but now I'm trying it again.
> >
> > The server is running RedHat and I tellnet in. Chris Little gave me a
> > snapshot gz file and I placed it on my server and extracted the
> archive. I
> > ran make and I did not see any error messages. It created
> > sword/lib/libsword.a and sword/lib/libsword.so
> >
> > I then tried to run su. It asked me for a password. I don't
> know what su is,
> > but I'm assuming that it is trying to do something in a directory above
> > mine. Since it is a webhosting account, I don't have access all
> the way to
> > the root of the machine.
> >
> > So my question... What is su trying to do and is there any
> config file that
> > I can change to have it do its thing in a directory I have access to?
> >
> > Thank-you for being patient with me. I'm new at this and I'm
> trying my very
> > best.
> su is the command to "switch user", i.e. change to another user
> (usually with
> more priviledges) to do some work.  By default, the user is "root" and the
> command is "sh".  So you need to give it your root password.  Not having
> compiled/installed sword on my machine, I can only guess as to
> what's going
> on, but I bet I can get close. :-)  You're probably doing something like:
> 	make
> 	su 		(and give your root password)
> 	make install	(while you're root)
> 	exit		(this may be implied)
> The reason to "su" is because install is going to copy the files
> into places
> (like /usr/local/lib and bin) which the average user doesn't have
> permissions
> to do.  Try "man su" for more info.
> HTH,
> Kevin