[sword-devel] su

sword-devel@crosswire.org sword-devel@crosswire.org
Sun, 04 Feb 2001 20:34:40 -0600

"Don A. Elbourne Jr." wrote:
> I'm trying to compile Sword on my web server again. I tried about a month
> ago and got too frustrated.  :-) but now I'm trying it again.
> The server is running RedHat and I tellnet in. Chris Little gave me a
> snapshot gz file and I placed it on my server and extracted the archive. I
> ran make and I did not see any error messages. It created
> sword/lib/libsword.a and sword/lib/libsword.so
> I then tried to run su. It asked me for a password. I don't know what su is,
> but I'm assuming that it is trying to do something in a directory above
> mine. Since it is a webhosting account, I don't have access all the way to
> the root of the machine.
> So my question... What is su trying to do and is there any config file that
> I can change to have it do its thing in a directory I have access to?
> Thank-you for being patient with me. I'm new at this and I'm trying my very
> best.

su is the command to "switch user", i.e. change to another user (usually with
more priviledges) to do some work.  By default, the user is "root" and the
command is "sh".  So you need to give it your root password.  Not having
compiled/installed sword on my machine, I can only guess as to what's going
on, but I bet I can get close. :-)  You're probably doing something like:
	su 		(and give your root password)
	make install	(while you're root)
	exit		(this may be implied)

The reason to "su" is because install is going to copy the files into places
(like /usr/local/lib and bin) which the average user doesn't have permissions
to do.  Try "man su" for more info.