Still not working (was: [sword-devel] Problems with the Hitchcocks and Smith lexicons)

Chris Little
Wed, 12 Dec 2001 16:17:42 -0800

> Chris, I dowloaded and installed ythe fixed Version of the Hitchcocks
> lexicon
> and tested it. I'm sorry it still doesn't work.

I didn't update it yet. :)  I'm still working on ICU, finishing a more
complete Cyrillic-Latin transliterator.

> Is it possibe that it's a bug in Sword which was introduced with all
> cool changes in the API? I suspect this because the Hitchcoks module
> stopped
> working between Sword updates. I had the same data on disk all the
> but
> the lading of the module stopped working wat one point (sorry, I do
> remember) . But this was probably after 1.5.2.
> We did not change anything in BibleTime's code related to the loading
> the
> items.

No, it's definitely a module error.  It won't manifest itself in casual
use of a module unless you access the words near the
mis-alphabetization.  So the module will work pretty well in BibleCS,
but since BibleTime queries all of a module's keys when it is selected
it goes into an infinite loop and hangs.