[sword-devel] Packaging Sword for Debian, compile problems

Ben Armstrong sword-devel@crosswire.org
Sun, 10 Sep 2000 20:22:24 +0000 (GMT)

On Sun, 10 Sep 2000, Joachim Ansorg wrote:
> BibleTime 1.0 will take some time (at least 2 months), so you'll have enough 
> time.
> Don't package BibleTime 0.2x because 0.2x isn't maintained any more after the 
> next release (0.25).
> 1.0 will be the best BibleTime, it does use KDE2 so it's no problem.


> InstallMgr install the sword-modules (bibles, commentaries etc.), if you 
> provide some Debian packages of modules there's no need for the InstallMgr.
> RPM packages are already available on ftp.crosswire.org.

That's what I thought.  My first thought about packaging the modules was
to run the RPM packages thru alien and install the resulting debs to save
some work.  But alien did a horrible job.  Somehow, the conf files and
other stuff had the execute bit set!  So the resulting deb packages were
not 'lintian clean' (i.e. not conforming with Debian policy).  Now, if the
rpms could be cleaned up, I could still use them.  Otherwise, I'll have to
resort to manually packaging the sword modules.

    nSLUG       http://www.nslug.ns.ca      synrg@sanctuary.nslug.ns.ca
    Debian      http://www.debian.org       synrg@debian.org
[ pgp key fingerprint = 7F DA 09 4B BA 2C 0D E0  1B B1 31 ED C6 A9 39 4F ]
[ gpg key fingerprint = 395C F3A4 35D3 D247 1387  2D9E 5A94 F3CA 0B27 13C8 ]