PocketSword
  1. PocketSword
  2. PS-68

Easy Bookmarking, Tour Mode, Bookmark Importing, iOS App URL Scheme

    Details

    • Type: New Feature New Feature
    • Status: Closed (View Workflow)
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      We have Bible studies and the lessons reference many Bible verses. I would like to enter all the references for a lesson easily. As we go through the lesson, we would go to each verse, so please, let it be easy to jump to the previous and next verse we have bookmarked.

      My current solution is highlighting each verse and taking a screenshot. I then put all the screenshots in a new photo album for the lesson. I like being able to swipe to the next verse.

      Please, make it easier to enter bookmarks into a folder. For example, let me type all the references in a text editor, copy and paste the list to a textbox to import it as bookmarks in a folder. Another example, let us import bookmark folders from a text file in a CSV format or JSON.

      An easier way for you, would be to accept URLs for a reference to the app, so we could make webpages link to verses. When it opens, jump to and highlight the verse(s).

      pocketsword://translation/book/chapter/verse-start(/verse-end)

      I guess what I really want would be like a tour mode in other applications. We define a list of destinations and jump to the next destination with a swipe.

        Activity

        Nic Carter added a comment -

        Seems sorted with http://sidetweet.github.com/pocketsword-verses/
        A Tour mode is not on the horizon, the URL stuff is a hidden feature, but implemented with the above website!
        Highlighting is something that will be fixed, but that feature request is a duplicate of other bug reports

        Thanks heaps!


          People

          • Assignee:
            Nic Carter
            Reporter:
            Side Tweet
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: