Details

    • Type: Bug Bug
    • Status: Closed (View Workflow)
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.4.1b6
    • Fix Version/s: 1.4.2b1
    • Component/s: None
    • Labels:
      None

      Description

      When there is section headings, the verse no will be shown in next line but the corresponding verse will go to the other next line.
      e.g.

      God created the heaven and the earth <<<section heading
      1 <<<verse
      In the beginning, God created the heaven and the earth. 2 And the earth was formless... <<<corresponding verse fallen to next line

        Activity

        Nic Carter added a comment -

        This bug is probably in the API? But other modules with paragraphs work fine in PocketSword (such as the ESV), so perhaps you need to modify your OSIS for this to work? Unless you are certain that your OSIS is well formed, I am going to close this bug. But even if it is valid OSIS, our API does have certain issues that you can work around and still create valid OSIS. Perhaps you could email the sword-devel mailing list and ask there?

        Nic Carter added a comment -

        sorted. Also was visible in the LEB. see http://sword-dev.350566.n4.nabble.com/SWORD-handling-of-OSIS-paragraphs-td359793.html for more details of the mess!

        Nic Carter added a comment -

        Just another comment. I finally got around to testing this in Xiphos and it does not work as you said. I suggest that you go back and test your module properly in the different front-ends. I have tested it in the cutting-edge version of Xiphos (about to be released, I believe?), and it displays with the verse number on a different line to the verse text (for example, Luke ch1). Rather than ask each and every front-end to modify their code to get your module to work, I suggest you fix up your module so that it will work properly everywhere. That way you don't need to wait for them to update their applications?
        Anyway, this fix will appear in the next version of PocketSword. :)

        Ko Chiu Shun added a comment -

        Thanks for your reply.
        I found that Xiphos does not work indeed, but Bibledesktop works.

        Nic Carter added a comment -

        Please test this in v1.4.2 of PocketSword which was just released this week. Should work as intended now.


          People

          • Assignee:
            Nic Carter
            Reporter:
            Ko Chiu Shun
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: