Details

    • Type: Bug Bug
    • Status: Closed (View Workflow)
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.2.1
    • Fix Version/s: 1.2.2b1
    • Component/s: Translation
    • Labels:
      None
    • Environment:

      iPhone 3.1.2

      Description

      The box for selecting book is not in Chinese. The version 1.2.0 did not have this problem.

        Activity

        Nic Carter added a comment -

        I'm trying to reproduce this, but I can't. Can you confirm that it still occurs on subsequent launches of the app?

        If it does still occur, can you try switching your iPhone's language to English and then back to Chinese and see if that fixes it?

        Either way, let me know and I'll try to hunt down the issue & try to prevent it happening in the future.

        Barry Tang added a comment -

        Thanks for your reply. I tried to switch the language preference but still have problem. My iPhone is jailbreak (3.1.2 - 7D11), not sure if it is related.

        Barry Tang added a comment -

        I tried Japanese and French, both are ok. But Simplify Chinese and Traditional Chinese do not work. Thanks.

        Nic Carter added a comment -

        The way I handle both Simplified and Traditional Chinese changed between v1.2.0 and v1.2.1 and the only thing I can think of is that the upgrade from v1.2.0 to v1.2.1 didn't work properly for you, and so you didn't get the new translations. I have now modified the code to try to make sure it won't happen for future updates, which will be incorporated into v1.2.2, but for now, you could try to remove PocketSword and add it again from the App Store. Unfortunately you'd need to install your Bibles again, but I think that would probably be the quickest solution, rather than waiting for v1.2.2 to be released.
        Sorry about that!

        Barry Tang added a comment -

        I tried to remove it and add it again from the App Store, it doesn't help. Is it possible for me to get the 1.2.0 ipa so that I can restore it manually? Thank you for developing PocketSword, it is really good.

        Nic Carter added a comment -

        Shoot me an email (you can use the "Email Us" button in PocketSword if you don't have my email address). Due to the security with the iPhone OS, I can't just give you the 1.2.0 ipa. But there are other options we can pursue.

        Nic Carter added a comment -

        Argh, sorry, found this bug.

        Nic Carter added a comment -

        The way Chinese is done is tricky - it can either be zh-Hans (Simplified Chinese) or zh-Hant (Traditional Chinese). But I have to handle 2 localisation methods: both the SWORD lib localisation and then the Apple iPhone OS localisation. Unfortunately, they are only semi-compatable, and I need to massage things for both types of Chinese. And there is a bug in that code that was introduced in v1.2.1, when I added the Simplified Chinese book names.
        This will be fixed in v1.2.2!
        Barry, you can still send me an email and I have a work around for you that will work until 1.2.2 comes out.


          People

          • Assignee:
            Nic Carter
            Reporter:
            Barry Tang
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: