Module Tools
  1. Module Tools
  2. MODTOOLS-56

osis2mod lies when a verse is not in the specified versification

    Details

    • Type: Bug Bug
    • Status: Closed (View Workflow)
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
    • Environment:

      osis2mod: $Rev: 2834 $

      Description

      Hi all,

      I noticed that osis2mod outputs incorrectly verse reference when a verse in not in the versification.
      I will explain the issue with FreJND (currently available in the beta repository).
      You can download the OSIS file at http://koocotte.org/darby/darby.osis.bz2.

      osis2mod outputs (I cut the output) :

      INFO(V11N): Lev.5.21 is not in the KJV versification. Appending content to Lev.5.19
      INFO(WRITE): Appending entry: Lev.5.19: <div type="x-milestone" subType="x-preverse" sID="pv379"/><div sID="gen643" type="paragraph"/> <div type="x-milestone" subType="x-preverse" eID="pv379"/>Et l'<divineName>Éternel</divineName> parla à Moïse, disant :
      INFO(V11N): Lev.5.22 is not in the KJV versification. Appending content to Lev.5.19
      INFO(WRITE): Appending entry: Lev.5.19: Si quelqu'un a péché, et a commis une infidélité envers l'<divineName>Éternel</divineName>, et a menti à son prochain pour une chose qu'on lui a confiée, ou qu'on a déposée entre ses mains, ou qu'il a volée, ou extorquée à son prochain ;
      INFO(V11N): Lev.5.23 is not in the KJV versification. Appending content to Lev.5.19
      INFO(WRITE): Appending entry: Lev.5.19: ou s'il a trouvé une chose perdue, et qu'il mente à ce sujet, et qu'il jure en mentant à l'égard de l'une de toutes les choses qu'un homme fait de manière à pécher en les faisant<note n="f" osisID="Lev.5.22_1" osisRef="Lev.5.22"><hi type="italic">litt.</hi>: par elles.</note> ;
      INFO(V11N): Lev.5.24 is not in the KJV versification. Appending content to Lev.5.19
      INFO(WRITE): Appending entry: Lev.5.19: alors, s'il a péché et qu'il soit coupable, il arrivera qu'il rendra l'objet qu'il a volé, ou la chose qu'il a extorquée, ou le dépôt qui lui a été confié, ou la chose perdue qu'il a trouvée,
      INFO(V11N): Lev.5.25 is not in the KJV versification. Appending content to Lev.5.19
      INFO(WRITE): Appending entry: Lev.5.19: ou tout ce à l'égard de quoi il a juré en mentant ; et il restituera le principal, et ajoutera un cinquième par-dessus ; il le donnera à celui à qui cela appartient, le jour de son sacrifice pour le délit.
      INFO(V11N): Lev.5.26 is not in the KJV versification. Appending content to Lev.5.19
      INFO(WRITE): Appending entry: Lev.5.19: Et il amènera, pour l'<divineName>Éternel</divineName>, au sacrificateur, son sacrifice pour le délit, un bélier sans défaut, pris du menu bétail, selon ton estimation, en sacrifice pour le délit.
      INFO(V11N): Lev.6 is not in the KJV versification. Appending content to Lev.5.19
      INFO(WRITE): Appending entry: Lev.5.19: Et le sacrificateur fera propitiation pour lui devant l'<divineName>Éternel</divineName> ; et il lui sera pardonné, quelle que soit la faute qu'il ait faite en laquelle il s'est rendu coupable. <div eID="gen643" type="paragraph"/> <chapter chapterTitle="Chapitre 5" eID="gen638" osisID="Lev.5"/>
      INFO(V11N): Num.14 is not in the KJV versification. Appending content to Num.13.33
      INFO(WRITE): Appending entry: Num.13.33: Et nous y avons vu les géants, fils d'Anak, qui est [de la race] des géants ; et nous étions à nos yeux comme des sauterelles, et nous étions de même à leurs yeux. <div eID="gen882" type="paragraph"/> <chapter chapterTitle="Chapitre 13" eID="gen876" osisID="Num.13"/>

      References in bold are incorrect.

      In fact Lev.5.20-26 are present in the OSIS file, but they are not in the KJV!
      osis2mod should say :

      INFO(V11N): Lev.5.20 is not in the KJV versification. Appending content to Lev.5.19
      INFO(WRITE): Appending entry: Lev.5.19: <div type="x-milestone" subType="x-preverse" sID="pv379"/><div sID="gen643" type="paragraph"/> <div type="x-milestone" subType="x-preverse" eID="pv379"/>Et l'<divineName>Éternel</divineName> parla à Moïse, disant :
      INFO(V11N): Lev.5.21 is not in the KJV versification. Appending content to Lev.5.19
      INFO(WRITE): Appending entry: Lev.5.19: Si quelqu'un a péché, et a commis une infidélité envers l'<divineName>Éternel</divineName>, et a menti à son prochain pour une chose qu'on lui a confiée, ou qu'on a déposée entre ses mains, ou qu'il a volée, ou extorquée à son prochain ;
      INFO(V11N): Lev.5.22 is not in the KJV versification. Appending content to Lev.5.19
      INFO(WRITE): Appending entry: Lev.5.19: ou s'il a trouvé une chose perdue, et qu'il mente à ce sujet, et qu'il jure en mentant à l'égard de l'une de toutes les choses qu'un homme fait de manière à pécher en les faisant<note n="f" osisID="Lev.5.22_1" osisRef="Lev.5.22"><hi type="italic">litt.</hi>: par elles.</note> ;
      INFO(V11N): Lev.5.23 is not in the KJV versification. Appending content to Lev.5.19
      INFO(WRITE): Appending entry: Lev.5.19: alors, s'il a péché et qu'il soit coupable, il arrivera qu'il rendra l'objet qu'il a volé, ou la chose qu'il a extorquée, ou le dépôt qui lui a été confié, ou la chose perdue qu'il a trouvée,
      INFO(V11N): Lev.5.24 is not in the KJV versification. Appending content to Lev.5.19
      INFO(WRITE): Appending entry: Lev.5.19: ou tout ce à l'égard de quoi il a juré en mentant ; et il restituera le principal, et ajoutera un cinquième par-dessus ; il le donnera à celui à qui cela appartient, le jour de son sacrifice pour le délit.
      INFO(V11N): Lev.5.25 is not in the KJV versification. Appending content to Lev.5.19
      INFO(WRITE): Appending entry: Lev.5.19: Et il amènera, pour l'<divineName>Éternel</divineName>, au sacrificateur, son sacrifice pour le délit, un bélier sans défaut, pris du menu bétail, selon ton estimation, en sacrifice pour le délit.
      INFO(V11N): Lev.5.26 is not in the KJV versification. Appending content to Lev.5.19
      INFO(WRITE): Appending entry: Lev.5.19: Et le sacrificateur fera propitiation pour lui devant l'<divineName>Éternel</divineName> ; et il lui sera pardonné, quelle que soit la faute qu'il ait faite en laquelle il s'est rendu coupable. <div eID="gen643" type="paragraph"/> <chapter chapterTitle="Chapitre 5" eID="gen638" osisID="Lev.5"/>
      INFO(V11N): Num.13.34 is not in the KJV versification. Appending content to Num.13.33
      INFO(WRITE): Appending entry: Num.13.33: Et nous y avons vu les géants, fils d'Anak, qui est [de la race] des géants ; et nous étions à nos yeux comme des sauterelles, et nous étions de même à leurs yeux. <div eID="gen882" type="paragraph"/> <chapter chapterTitle="Chapitre 13" eID="gen876" osisID="Num.13"/>

        Activity

        David Haslam added a comment -

        Please refer to http://crosswire.org/wiki/Alternate_Versification

        The problem is that the FreJND translation ideally requires an av11n.

        As yet in SWORD there are no av11ns specifically defined for various French Bibles.
        You can research whether any of our existing av11ns give a closer match for the FreJND than the default KJV v11n.

        There has been a reluctance to create further av11n definitions, except where one is absolutely necessary.
        This should be taken up as an issue to discuss further with our software developers.

        David Haslam added a comment -

        The CrossWire repository for Bibles with Alternate Versification contains three French Bibles.

        FreCrampon for which Versification=Vulg (this being a Catholic translation)
        FreKhan for which Versification=MT (this is OT only)
        FreSegond for which Versification=Vulg

        Please review whether Versification=Vulg might be a better match to the requirements of FreJND than the default KJV.

        DM Smith added a comment -

        Y.D. Thanks for your report. I see where the problem occurs: When the next verse is started, it handles the last verse. It should use the osisID of the verse being handled.

        David, Yes he should use a different v11n, but this is a reported problem with how osis2mod produces diagnostics.

        Y. D. added a comment -

        You can research whether any of our existing av11ns give a closer match for the FreJND than the default KJV v11n.

        That's what I wanted to do with a bash script but it fails (to end) see http://www.crosswire.org/tracker/browse/MODTOOLS-55

        Please review whether Versification=Vulg might be a better match to the requirements of FreJND than the default KJV.

        No it won't.
        Indeed osis2mod . darby.osis.xml | grep "INFO(V11N)" | wc -l gives me 80 verses missing in the KJV versification, while it gives me 807 verses missing in the Vulg versification.

        Thank you for your help.

        Y. D. added a comment - - edited

        The file is no longer available on koocotte.org, I put it on my own server so you can get the file at : DEAD LINK
        EDIT: Again available on koocotte.org

        Chris Little added a comment -

        fixed in r3016

        DM Smith added a comment -

        Chris, Thanks for finding and fixing this!


          People

          • Assignee:
            Chris Little
            Reporter:
            Y. D.
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: