Details

    • Type: Improvement Improvement
    • Status: Resolved (View Workflow)
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      Test filters with latest OSIS modules: NASB, ESV, KJV2003
      Review/Update OSIS import/export tools.

        Activity

        Daniel Glassey added a comment -

        Could someone with access to the source texts take this on and check it. I think this should be done for 1.5.8

        Troy A Griffitts added a comment -

        See comments on this forum thread for additional possible bugs:

        http://www.crosswire.org/forums/mvnforum/viewthread?thread=274

        Deactivated added a comment -

        Hi!
        Following advice given in this thread I've encoded part of the New Testament for Polish Bible Warszawsko-Praska. Trying hard to encode the printed original in OSIS representing all the details I've encountered some quite serious problems.

        Following strong request of not posting cult material, copyrighted especially I've created neutral OSIS test file explaining all the problems I've encountered. This file is available on my web page http://panda.bg.univ.gda.pl/~krzbia/test.osis.xml .
        Here I'll list all the problems found together with brief explanations

        paragraph markers <p> and </p> placed outside of verse tags are not parsed correctly by osis2mod, that is closing tag is not included. This problem was confirmed earlier by Osk, but still it is a unsolved problem
        a note containing reference spanning a fragment of text in which there is <p> and not </p> results in a popup note containing some RTF rubbish
        construct <div><title>A title</title>... placed at the beginning of the chapter couses the title to be ignored
        construct <div><title>1 title</title><div><title>2 title</title> on the beginning of the chapter - the '1 title' is ignored
        construct <div><title>1 title</title><div><title>2 title</title><div><title>3 title</title> at the beginning of the chapter - only '3 title' is shown, and all the verses from the inner <div> are joined together as one?!
        construct <div><title>1 title</title><div><title>2 title</title> in the middle of the chapter results in the titles presented in the wrong sequence
        construct <div><title>1 title</title><div><title>2 title</title><div><title>3 title</title> in the middle of the chapter couses the titles to be presented in the order 3 1 2.
        A notes within <title></title> are not rendered as popups but included in the title

        All this cases are present in the test file and can be shown in the Sword.
        Important! The tests I've performed were done using lates osis2mod and Sword for Windows v 1.5.8pre3.

        Greetings and really looking for help.
        Christopher

        Deactivated added a comment -

        I just added the comments from the forum. I am not an expert here, but it seems that these issues are indeed serious.
        We should listen to what people using our software say.

        DM Smith added a comment -

        I think these are fixed with the latest changes to osis2mod.

        Chris Little added a comment -

        Changed priority & issue type since we've got fairly good OSIS support across the board.

        Daniel Owens added a comment -

        Book introductions are a gap in OSIS support. The following elements are not supported: <p>, <list>, and <item>. See the VietNVB for an example. Paragraphs do not break, and the list is just left as a mass paragraph.

        DM Smith added a comment -

        I think the problem was that osis2mod reorganized the tags and threw out some tags that it thought weren't needed in the module.

        It now retains all input and does not reorder any of it.

        I think book intros work now using osis2mod from SVN HEAD on trunk. Can you verify.

        DM Smith added a comment -

        Haven't heard to the contrary.


          People

          • Assignee:
            DM Smith
            Reporter:
            Troy A Griffitts
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: