[sword-devel] Av11n modules - was Deuterocanonical books / Apocrypha

Barry Drake bdrake at crosswire.org
Mon Feb 3 09:28:14 MST 2014

On 03/02/14 14:39, Greg Hellings wrote:
> If you're building out of SVN you can either build with CMake or 
> you'll have to run ./autogen.sh before you invoke ./usrinst.sh

Thanks - got it.  After building and installing icu-sword I got most of 
the way through but still have some fatal errors.  At first, I got 
errors because the linker couldn't find -lustdio which I think is a 
reference to some of the icu stuff.  I tried the brute force method of 
commenting out the reference in the makefiles, and nearly get a build.  
It made buildtest, but when I run it, I get "./buildtest: error while 
loading shared libraries: libicui18n.so.46: cannot open shared object 
file: No such file or directory".  I have that library which was 
installed by the icu build, but I've no idea whether or not I need to 
have the icu stuff in a specific place.  Sorry to ask what may be silly 
questions, but I am not sure where and how to arrange the svn checkouts.

God bless,        Barry.

More information about the sword-devel mailing list