[sword-devel] cmake python bindings user location

Greg Hellings greg.hellings at gmail.com
Fri Jun 21 06:44:23 MST 2013

On Thu, Jun 20, 2013 at 8:04 AM, Ben <cricketc at gmail.com> wrote:

>> Good catch - looks like I accidentally grep'd for the wrong string when
>> I was making sure I had gotten them all. I have added the additional
>> option of BINDIR that captures the appropriate value. You can try again
>> now, if you'd like.
> Looks good.

Good to hear.

>>     Also, I'm not sure it's causing anything to fail, but the name of
>>     the icu directory seems to be missing something (1.6.2_icu_).
>> Hmm, maybe. I'm very un-knowledgeable on what the ICU stuff all is
>> supposed to be. That could explain the missing data warnings I see when
>> I run the modules frequently. I'll look into that.
> OK. I tried running make tests, but the osistest doesn't seem to be
> included. It'd be nice to get the test suite passing.
> As a start for fixing osistest, I added osistest to the list of test
> programs in tests/CMakeLists.txt, and the following command to
> tests/testsuite/CMakeLists.**txt:
> osistest still fails for me, but I'm not sure it's related to cmake at
> all. May not be worth holding up the release if the tests pass for others.

Since the testsuite is really developer-only and basically only Troy uses
or maintains it, I've not been on top of keeping the CMake portion
up-to-date. Troy uses and maintains the autofoo for the library and so he
just has them churning along as he needs. I'll see about adding the missing
command - the main difference there is that I force the CMake build to be
in a different directory whereas most autotools people will build in the
same directory as source.

Did you try running the testsuite with autotools to see if it works?


> -Ben
> ______________________________**_________________
> sword-devel mailing list: sword-devel at crosswire.org
> http://www.crosswire.org/**mailman/listinfo/sword-devel<http://www.crosswire.org/mailman/listinfo/sword-devel>
> Instructions to unsubscribe/change your settings at above page
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.crosswire.org/pipermail/sword-devel/attachments/20130621/9c424202/attachment.html>

More information about the sword-devel mailing list