[sword-devel] Glosses vs Ruby

DM Smith dmsmith at crosswire.org
Fri Jun 14 08:36:42 MST 2013

The other thing that is needed is a minimum sword version of 1.7 in the module conf for OSISGlosses.

Use OSISRuby for earlier versions of SWORD front-ends.

-- DM

On Jun 13, 2013, at 8:36 PM, Nic Carter <niccarter at mac.com> wrote:

> On 13/06/2013, at 9:15 PM, admin at bible.salterrae.net wrote:
>>> Are the Japanese modules (in beta) going to be updated to reflect this?
>> What should I do to relect that?
> Moving forward, if you are using "Ruby" or "Glosses", you should have the line:
> GlobalOptionFilter=OSISGlosses
> to signify that the front-end should have the ability to be able to toggle glosses on and off.
> I believe that glosses/ruby isn't supported in modules that aren't marked up in OSIS.  :)
> I hope that helps?  Thanks, ybic
> 	nic...  :)
> ps: The previous way was to have "=OSISRuby", but that has been deprecated and support for that may be removed "at any point in the future" from the API, according to the definition of "deprecated"...  ;)
> _______________________________________________
> sword-devel mailing list: sword-devel at crosswire.org
> http://www.crosswire.org/mailman/listinfo/sword-devel
> Instructions to unsubscribe/change your settings at above page

More information about the sword-devel mailing list