[sword-devel] UTF8Transliterator messages

Greg Hellings greg.hellings at gmail.com
Wed Jul 17 07:10:28 MST 2013

So I've been plagued in the CMake builds by this message:
UTF8Transliterator: ICU: no resource index to load
UTF8Transliterator: ICU: status U_MISSING_RESOURCE_ERROR

Now it's expanding out to repeat itself four times when I run a utility
like diatheke, and Peter has claimed he sees the message when running the
Python bindings in Ubuntu when building with autotools.

Is there anyone who knows what this might be referring to, and how I can
squelch this? I just tried building and adding libicudata.so to the build
process, but to no avail. I still get the same number of messages and
warnings. I'm attaching my build output to see if anyone can see what is
present/missing in CMake that the autotools seems to get right (I'm
guessing it still lacks the above message?).

These warnings have been present throughout the history of the CMake build,
but I'd like to squash them if anyone can see what's going on. I'm quite
out of ideas at this point. :-/

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.crosswire.org/pipermail/sword-devel/attachments/20130717/3b81c4ac/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: build.log.xz
Type: application/octet-stream
Size: 9688 bytes
Desc: not available
URL: <http://www.crosswire.org/pipermail/sword-devel/attachments/20130717/3b81c4ac/attachment.obj>

More information about the sword-devel mailing list