[sword-devel] CMake ICU (was Re: cmake python)

Greg Hellings greg.hellings at gmail.com
Fri Jan 4 15:09:06 MST 2013

On Sat, Dec 22, 2012 at 12:51 PM,  <cricketc at gmail.com> wrote:
> On Wed, Dec 19, 2012 at 9:06 PM, Greg Hellings <greg.hellings at gmail.com> wrote:
>>> On Tue, Dec 18, 2012 at 9:27 PM,  <cricketc at gmail.com> wrote:
>>> Here's a patch that helps some with osistest. I still get the
>>> following error when I run osistest, though:
>>> UTF8Transliterator: ICU: no resource index to load
>>> UTF8Transliterator: ICU: status U_MISSING_RESOURCE_ERROR
>> This is because it's not finding the locales or some such. I very
>> frequently get it, mainly when running from an uninstalled SWORD
>> instance but it happens other times even on install.
>> I'll see about applying these patches.
> Here's patch that I think helps with the ICU support. It finds the
> genrb command, and then also sets the ICU_VERSION variable, like the
> configure build system does. (The osis test still fails, but it
> doesn't have the UTF8Transliterator error.)

Your patch was on the right path but used icu-config which is horridly
broken in native Windows builds (it's a Bash script) or in cross-build
environments from Linux (it explodes looking for a .so library when it
should look for a .dll).

I have substituted using CMake's built-in pkg-config functions to pull
out the modversion variable of libicuuc, which is one of the few that
we actually link directly against.

I wish I could tell you why that fixes the issue, but it does. Thank
you much, because that has been bugging me for a long time. The fix
should be in the SVN HEAD now.


> -Ben
> _______________________________________________
> sword-devel mailing list: sword-devel at crosswire.org
> http://www.crosswire.org/mailman/listinfo/sword-devel
> Instructions to unsubscribe/change your settings at above page

More information about the sword-devel mailing list