[sword-devel] FirefoxOS bible app

Stephan info at tetzels.de
Thu Dec 26 19:56:10 MST 2013


> Yes, as a packaged app it works! Yuhoooo! Which means I have at least
> ESV working on my mobile. Unfortunately, I don’t seem to be able to open
> (both on the phone as well as in 1.1 simulator) any Czech bible (tried
> CzeBKR and CzeCEP).

You are using the modules from the CrossWire repos, right? I will test 
it later this day.

> ESV works in my Peak, but in the 1.1 simulator, I get these errors when
> installing it:
> TypeError: i is undefined app.js:209
> Error in parsing value for 'width'.  Declaration dropped.  index.html
> "http://www.crosswire.org/sword/servlet/SwordMod.Verify?modName=ESV&main=true&pkgType=raw"
> app.js:224
> GET http://www.crosswire.org/sword/servlet/SwordMod.Verify [HTTP/1.1 200
> OK 421ms]
> Error in parsing value for 'right'.  Declaration dropped.  index.html
> Error in parsing value for 'bottom'.  Declaration dropped.  index.html
> UnknownError app.js:204

I got this error, too. You need to remove/uninstall the app to delete 
the app's indexeddb. I did some changes to the database and a clean 
install will solve this.

> When trying CzeCEP in 1.2 simulator I get the same error (Unknown Error
> in app.js:204). In both cases also [objectEvent] jumps up. No idea, what
> it is.

The reason for the unkown error in the simulator is, that you have the 
5MB indexeddb limit and AFAIK you can't extend it in the simulator. So 
you can only install 1 or sometimes to modules in the simulator.

> Also I got with ESV in 1.2 this error:
> TypeError: this.currentModule.getVersesInChapter is not a function
> app.js:221

I think you need to update the sword.js submodule, because I've added 
this function the last days.

> Also, when trying to install CzeCEP in 1.2 I get it installed, but it
> never finishes when trying to display Mat 1.1 and I get an error
> TypeError: i is undefined app.js:209

see above.


More information about the sword-devel mailing list