[sword-devel] USFM -> OSIS -> Sword

David Haslam dfhmch at googlemail.com
Thu Mar 8 01:22:34 MST 2012

Michael asks,
"Is there any way we can tag a module as being of a version that requires
support for alternate versification and/or support for RtoL scripts? 
Then only front ends with that capability could display it, and we wouldn't
have to withhold the module from the front ends that don't."

We can already specify Versification and Lang in the module conf file.

It's up to a front-end designer to choose whether to ignore the former if
that particular front-end does not yet fully support av11n.
We don't know of an application that refuses to [try to] install a module on
this grounds.

Support for av11n isn't merely a yes/no gate anyway. 
It depends whether we're thinking primarily of deuterocanonical books being
part of the module,
or whether we're still thinking of the 66-book protestant canon, yet with
differences in how many verses in each chaper, etc.

Av11n & RtL support by notable front-ends is tabulated in 

The documented coverage is incomplete and blotchy - that table needs
frequent attention to keep it up to date.


View this message in context: http://sword-dev.350566.n4.nabble.com/WikiMedia-Extension-SyntaxHighlight-GeSHi-tp4284998p4455869.html
Sent from the SWORD Dev mailing list archive at Nabble.com.

More information about the sword-devel mailing list