[sword-devel] Inuktitut Version Sword Module

refdoc@gmx.net refdoc at gmx.net
Tue Jul 10 21:31:54 MST 2012

It is not likely the language. If xiphos does not recognise a language, the module turns up still, under other, unknown, or some such. The usual problems if a module simply does not show, are path problems or compression problems. Use first an uncompressed module.

Sent from my HTC

----- Reply message -----
From: "Andrew Thule" <thulester at gmail.com>
To: <sword-devel at crosswire.org>
Subject: [sword-devel] Inuktitut Version Sword Module
Date: Wed, Jul 11, 2012 5:21 am

I'm working on an Inuktitut Version of the bible to make a sword
module.  The OSIS form is based upon example set in kjvxml.zip
The header looks as follows:

-=-=- HEAD -=-=-
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<osis xmlns="http://www.bibletechnologies.net/2003/OSIS/namespace"
<osisText osisIDWork="INK" osisRefWork="defaultReferenceScheme" xml:lang="iu">

                <work osisWork="IUV">
                        <title>Inuktitut Version</title>
                        <identifier type="OSIS">Bible.IUV</identifier>
                <work osisWork="defaultReferenceScheme">
        <div type="book" osisID="Gen" canonical="true">
-=-=- HEAD -=-=-

John 3:16 looks as follows:

<verse sID="John.3.16" n="16)" osisID="John.3.16"/>ᑍᒫᒃ ᑕᕝᕙ ᒎᑎᐅᑉ
ᓯᓚᖅᔪᐊᕐᖕᒥᐅᑦ ᓇᒡᓕᒋᕔᑦ ᐃᕐᖕᓂᑐᐊᓂ ᑐᓂᖕᒪᒍ, ᓇᓪᓕᐊᑦ ᑖᑦᓱᒧᖓ ᐅᒃᐱᖅᑐᖅ ᐊᓯᐅᖁᓇᒍ ᓄᖑᓱᐃᑦᑐᒥᒡᓕ
ᐃᓅᓯᖃᖁᓪᓗᒍ. <verse eID="John.3.16"/>

Here's the iuv.conf file:

Description= Inuktitut Version
LCSH=Bible. Inuktitut.
DistributionLicense=Not for distribution (yet).

You get the idea.

I've not be able to get it to show up in Bibletime, Xiphos, etc.  I
know how to install Sword modules (I've done lots).  I have it
compiling (only a few errors, mostly warnings and info):

You are running osis2mod: $Rev: 2708 $
INFO(WRITE): Appending entry: Mark.16.9: <div type="x-milestone"
subType="x-preverse" sID="pv10698"/><div sID="gen23373"
scope="Mark.16.9!)-Mark.16.10!)" type="majorSection"/>
<title>ᐊᒡᓚᒃᓯᒪᔪᑐᕾᑦ ᐊᓯᖏᑦ ᐅᑯᓂᖓ ᐃᓚᔭᐅᒃᑲᓐᓂᖅᓯᒪᕗᑦ</title> <div sID="gen23374"
type="paragraph"/> <div type="x-milestone" subType="x-preverse"
eID="pv10698"/>[ᑕᕝᕙ ᐊᕐᖕᓁᑦ ᐲᑦᑐᕉᓯᒧᐊᖅᐳᑦ ᐃᓚᓐᓇᕆᔭᖏᓐᓄᓪᓗ, ᐅᖃᖅᐳᓪᓗ ᓁᑦᑐᒥᒃ
INFO(WRITE): Appending entry: Mark.16.10: ᑕᒪᑐᒪᓕ ᑭᖑᓂᖓᒍᑦ, ᔩᓱᓯ ᓇᖕᒥᓂᖅ
ᑎᓕᓯᓚᐅᖅᐳᖅ ᐃᓕᓐᓂᐊᖅᑎᒥᓂᒃ ᓯᕿᓂᐅᑉ ᓄᐃᕕᐊᓂᑦ ᓯᕿᓂᐅᑉ ᓂᐱᕕᐊᓄᑦ ᑎᑭᓪᓗᑎᒃ. ᑕᒪᑐᒥᖓ ᐅᖃᐅᓯᖃᖅᓗᑎᒃ
ᐃᔨᖅᓯᒪᓚᐅᖅᑐᒥᒃ ᐃᓅᓯᖃᕐᖕᓇᖅᑐᒥᒃ ᐱᐅᓕᔭᐅᓂᕐᖕᒥᒡᓗ ᐃᓱᖃᖏᑦᑐᒧᑦ.]<note n="+"><reference
type="source">16:10</reference>ᐃᓚᖏᑦ ᐊᒡᓚᒃᓯᒪᔪᑐᖃᕕᓃᑦ ᐋᖅᑭᒃᓱᖅᑕᐅᕙᒃᑐᕕᓃᓪᓗ
ᐊᒡᓚᑐᕾᑦ ᓁᓐᓂᖅᓴᐅᖕᒪᑕ, ᐃᓚᖏᓪᓗ ᑕᑭᓂᖅᓴᐅᓪᓗᑎᒃ ᑕᕝᕙᓐᖓᑦ ᕚᓯᖓ 9-ᒥᑦ–20-ᒧᑦ
ᐃᓚᓯᒪᓪᓗᑎᒃ</note> <div eID="gen23374" type="paragraph"/> <div
eID="gen23373" scope="Mark.16.9!)-Mark.16.10!)" type="majorSection"/>
<div eID="gen22935" osisID="Mark" type="book"/>
WARNING(NESTING): verse Acts.15.23 is not well formed:(46,48)
INFO(V11N): Jude is not in the KJV versification. Appending content to
INFO(WRITE): Appending entry: 3John.1.14: <div type="x-milestone"
subType="x-preverse" sID="pv12443"/><div sID="gen26547"
type="paragraph"/> <div type="x-milestone" subType="x-preverse"
eID="pv12443"/>ᓮᒻᒪᓂᐅᑉ ᐃᓚᒋᓕᑎᑦ. ᐃᓚᓐᓇᕆᔭᑦᑎᓐᓂᑦ ᑕᕝᕙᐅᕗᑏᖅᑕᐅᕗᑎᑦ. ᓇᖕᒥᓂᖅᓗ
ᐃᓚᓐᓇᕆᔭᕗᑦ ᑕᕝᕙᐅᕗᑏᖅᐸᕗᑦ ᑍᑲᓃᑦᑐᑦ. <div eID="gen26547" type="paragraph"/>
<div eID="gen26545" scope="3John.1.13!)-3John.1.15!)" type="section"/>
<div eID="gen26530" osisID="3John" type="book"/>
SUCCESS: /usr/local/bin/osis2mod: has finished its work and will now rest

Yet I still can't it show up in my modules list.  I think this is a
language issue.  I've tried changing language to iu_CA ... i.e.
xml:lang="iu" (as well as in conf file).

Any ideas why I'm not seeing it show up?  What must I do to get the IU
language recognized?

sword-devel mailing list: sword-devel at crosswire.org
Instructions to unsubscribe/change your settings at above page
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.crosswire.org/pipermail/sword-devel/attachments/20120711/d7e7ed62/attachment.html>

More information about the sword-devel mailing list