[sword-devel] cmake python

cricketc at gmail.com cricketc at gmail.com
Sat Dec 22 11:51:35 MST 2012

On Wed, Dec 19, 2012 at 9:06 PM, Greg Hellings <greg.hellings at gmail.com> wrote:
>> On Tue, Dec 18, 2012 at 9:27 PM,  <cricketc at gmail.com> wrote:
>> Here's a patch that helps some with osistest. I still get the
>> following error when I run osistest, though:
>> UTF8Transliterator: ICU: no resource index to load
>> UTF8Transliterator: ICU: status U_MISSING_RESOURCE_ERROR
> This is because it's not finding the locales or some such. I very
> frequently get it, mainly when running from an uninstalled SWORD
> instance but it happens other times even on install.
> I'll see about applying these patches.

Here's patch that I think helps with the ICU support. It finds the
genrb command, and then also sets the ICU_VERSION variable, like the
configure build system does. (The osis test still fails, but it
doesn't have the UTF8Transliterator error.)

-------------- next part --------------
A non-text attachment was scrubbed...
Name: cmake_icu.diff
Type: application/octet-stream
Size: 993 bytes
Desc: not available
URL: <http://www.crosswire.org/pipermail/sword-devel/attachments/20121222/0c421ca8/attachment.obj>

More information about the sword-devel mailing list