[sword-devel] XML attribute delimiters in OSIS files?

Greg Hellings greg.hellings at gmail.com
Tue Oct 25 12:18:27 MST 2011

On Tue, Oct 25, 2011 at 2:14 PM, David Haslam <dfhmch at googlemail.com> wrote:
> I have discovered today that osis2mod output is incorrect for any text in
> which the delimiters used for the *sID* milestone attribute are not the same
> as the delimiters for the *eID* attribute in the same verse [or verse
> range].

If the sID and eID do not match (but should) then this is an error in
the XML document.  It's likely that osis2mod is handling them
correctly, it just looks like it's incorrect because the OSIS file is,
itself, wrong.  This is the type of "incorrect" that is beyond what an
XML Schema validation step is capable of detecting.


> This phenomenon was encountered in one of the Myanmar Bibles translations.
> btw. The XML files for most of their hosted translations are badly encoded
> on many other aspects of OSIS, not just XML attribute delimiters.
> As source text, most of these files are unsuitable for making a module that
> we could release. Perhaps the one exception is the Judson translation.
> David
> --
> View this message in context: http://sword-dev.350566.n4.nabble.com/XML-attribute-delimiters-in-OSIS-files-tp3907261p3937889.html
> Sent from the SWORD Dev mailing list archive at Nabble.com.
> _______________________________________________
> sword-devel mailing list: sword-devel at crosswire.org
> http://www.crosswire.org/mailman/listinfo/sword-devel
> Instructions to unsubscribe/change your settings at above page

More information about the sword-devel mailing list