[sword-devel] New (Beta) Version of Utilities (was Re: DevTools:ICU & Normalization?)

Greg Hellings greg.hellings at gmail.com
Wed Nov 16 00:38:16 MST 2011

On Thu, Oct 13, 2011 at 11:22 AM, David Haslam <dfhmch at googlemail.com> wrote:
> Thanks Greg.
> Do you happen to know which version of ICU was included when the Windows
> editions of the SWORD utilities were compiled?
> The latest available for download are still as in
> http://crosswire.org/ftpmirror/pub/sword/utils/win32/sword-utilities-1.6.2.zip
> sword-utilities-1.6.2.zip  dated 2010-10-22.

I have posted a test version of the utilities I just built to

*The latest version of the SWORD library code: 1.6.2+svn2671. This is
the latest dated to the moment of posting.
*Includes a patch from the Xiphos team that fixes some errors in
handling non-ASCII characters in file path names. This is a bug,
present in the engine, which has been known about for quite some time
now but which has never actually been fixed for anyone on Windows who
does not use Xiphos. This should at least allow users of the utilities
to avoid this pesky bug.

Known Issues:
*The package includes the latest version of ICU as of posting time
(4.8.1). However, I seem to have done the normal whoopsies of
compiling with only partial ICU support, as the utilities report to me
UTF8Transliterator: ICU: no resource index to load
UTF8Transliterator: ICU: status U_MISSING_RESOURCE_ERROR
which I have seen before, many times, but cannot for the life of me
remember how it is supposed to be fixed. If anyone knows what my
problem is here, please let me know so I can fix it and post back a
version with the fully correct linking!

I tested the system, fundamentally, working on Windows Server 2008. It
was able to install with installmgr and read the installed module with
diatheke as long as I installed to C:\Users\<current user>\sword - any
other location and installmgr worked properly but diatheke couldn't
locate the resources.


More information about the sword-devel mailing list