[sword-devel] Ubuntu 11.04 (and libsword9 status)

Jonathan Marsden jmarsden at fastmail.fm
Sun May 1 00:25:14 MST 2011

On 04/30/2011 11:10 AM, Greg Hellings wrote:

> For some reason either Debian or Ubuntu refuses to get the latest
> BibleTime version.

If I remember this rightly, I was told (I think by Dmitrij) that the
latest BibleTime and Xiphos need libsword9.  I don't think I got a clear
explanation of what specific ABI changes were made in SWORD that require
this change from libsword8 to libsword9, or why Xiphos and BibleTime
need them.  Or if I did, it was too long ago and I have forgotten!

I don't know why, but libsword9 is *still* not in Debian as far as I can
see. not even in experimental or unstable.  Until it is in Debian, I
can't (usefully!) ask for a Bibletime 2.8.x package that depends on it
to be added to Debian.

As soon as libsword9 shows up in Debian, I will do my best to get a
current BibleTime package into Debian also.

Once packages are in Debian, we can request syncing of them into Ubuntu.
 This is generally pretty straightforward.  Sometimes it has to wait
until the packages get from unstable into testing, the rules on that
seem to vary over time :)

It would be good to get "caught up" with this stuff soon, so at least
Ubuntu 11.10 officially has a 2.8.x version of BibleTime in it!


More information about the sword-devel mailing list