[sword-devel] compile error on (x)ubuntu 11.10 : "_FTPLIB_NO_COMPAT" redefined

Jonathan Marsden jmarsden at fastmail.fm
Sun Dec 11 20:24:20 MST 2011

On 12/11/2011 06:45 PM, Paul A. Martel wrote:

> For the record, there was nothing so obvious as a "libcurl-dev"
> package listed in the package manager. The actual package that seems
> to have worked for me was "libcurl4-gnutls-dev". Other listed
> packages that I didn't try but that might have worked as alternatives
> (?) were "libcurl4-nss-dev" and "libcurl4-openssl-dev". I don't know
> if my (mostly blind) choice among these has any consequences for the
> functionality of my build products.

Not really; you made a sane choice.  The SWORD packages we build for
Debian and Ubuntu use libcurl4-gnutls-dev .  This is listed in the
debian/control file for the package.  Technically the openssl code is
not licence-compatible with the GPL, if I remember correctly, so we used
the GNUTLS codebase instead, to sidestep that issue.

In general, when packages exist, it can pay you to use them as a basis
for any work you do on trying to compile newer versions of their
upstream code, since the work of figuring out all the appropriate
build-time dependencies and flags has already been done for you by the
package creators.  Also, if you use packages, it makes it a lot easier
to uninstall your locally-created versions of things when the official
packages (eventually) catch up.


More information about the sword-devel mailing list