[sword-devel] Change to Synodal verse system

Troy A. Griffitts scribe at crosswire.org
Mon Aug 1 07:01:24 MST 2011

On 01/08/11 14:55, Chris Little wrote:
> We added the SynodalP v11n specifically to support IBT's texts, and
> that's probably as much as we can do to accommodate these texts.

OK, to be sure I understand the summary of the issue:

IBT has legacy Russian Bibles that use v11n "P"
We have Russian Bibles the use v11n "Synodal"
We have a special v11n "SynodalP" which lets our current software work
with IBT's legacy Russian Bibles.
IBT is redoing their modules to use our newer v11n scheme.

If this is correct, I think we have almost what David is suggesting.

We have 2 Synodal v11n systems supported.

The current situation then is this, IF the IBT modules specify "Synodal"
in their .conf file (which they probably do):

Current software written to support these modules (using SWORD 1.6.1 or
the custom fork of SWORD from IBT) will still work as expected, but will
not work with newer Russian Bibles which use our "Synodal" v11n.

This is fine, as we probably specify MinimumVersion=1.6.2 in all modules
which use our "Synodal" v11n system.  This means any frontends which are
compiled with 1.6.1 or previous will not show these modules available
for install and thus not supported-- this is true: they aren't supported
with this software-- there was not v11n in existence at the time which
included their extra verse in Ps.  An upgrade of software is necessary
for these people to see our new modules with our new versification.  If
they can see new Bibles, then they can see new software too.

Fine. But...

the caveat is that these older modules which specify "Synodal" will not
be usable in newer software.

So, do we have a problem?

We've already mentioned that IBT is migrating all their modules to our
"Synodal" v11n system.  Even if they don't rework the modules, they can
re-release the same modules with a .conf change to: Versification=SynodalP

Here's the only situation to consider:

Will there be a user with NEWER software and access to only OLDER IBT

All other scenarios are covered.

If someone decides this scenario is important to handle, they can:

If a newer frontend wishes to support legacy IBT modules, then they can
simply say:

If Module v11n == "Synodal" AND Module MinimumVersion < 1.6.2
Module v11n = "SynodalP"

I've just made SWMgr::CreateMod virtual to support this easily.



> Nothing we can do can fix issues created by Synodal-v11n texts created
> for 1.6.1 by third parties. Nothing we can do can fix incompatibility of
> pre-Sword-1.6 xulsword Synodal-oid texts with Sword 1.6.2+ frontends.
> --Chris
> _______________________________________________
> sword-devel mailing list: sword-devel at crosswire.org
> http://www.crosswire.org/mailman/listinfo/sword-devel
> Instructions to unsubscribe/change your settings at above page

More information about the sword-devel mailing list