[sword-devel] [bt-devel] linker problems with 1.6.0? - help needed

Jonathan Marsden jmarsden at fastmail.fm
Sun May 24 17:26:14 MST 2009

Martin Gruner wrote:

> we use the following stupid program to check that linking BibleTime against 
> Sword is going to work:
> ...

> However, after just upgrading to 1.6.0, I get the following error trying to 
> compile the test program: ...

cd cmake && g++ -I /usr/include/sword/ -lsword sword_linker_check.cpp

works fine for me here on Ubuntu Jaunty 9.04 amd64.  As does BibleTime
2.0 beta2 building and running against SWORD 1.6.0.

It really does seem to be something about your machine.  Can you retest
this on a freshly installed machine (or a freshly installed virtual
machine, if that's easier, which it usually is!)?


More information about the sword-devel mailing list